This Disappears When Logged In

Rose Hair Help.

Discussion in 'Arachnids General' started by biollantefan54, Apr 12, 2012.

  1. mld

    mld Subscribed User Premium Member

    You will have a few inches of substrate so she isn't going to be falling as far. They will usually not climb unless they are after something, like crickets that climb up foam backgrounds and also if your substrate is too moist it will climb frequently or make a fine web on the entire floor of your enclosure. If you are able to get that book make sure that its the 3rd edition!

    Quick question, do you have this T already or are you thinking about getting one.
     
  2. biollantefan54

    biollantefan54 Elite Member

    It won't let me go to page 3? When I click on it, stays on page 2.
     
  3. biollantefan54

    biollantefan54 Elite Member

    I cant see you new posts and it wont let me go to page 3 so if you can read this just start messaging me.
     
  4. mld

    mld Subscribed User Premium Member

    Page 3 of this post?
     
  5. Rich

    Rich Administrator Staff Member Premium Member

    Yes, it says page 3 of this post. lol What seems to be the problem?
     
  6. AjaMichelle

    AjaMichelle Elite Member

    Hey that website provides great information. :)
    I have a Chilean rose who dug a burrow and rearranged most of her enclosure then completed her second shed in my care. The humidity has recently increased in her enclosure and I think she's enjoying it. She's just started eating reliably after almost a two year fast!
     
  7. mld

    mld Subscribed User Premium Member

    The Op cannot see anything on page 3!
     
  8. mld

    mld Subscribed User Premium Member

    Yeah, I know, its seem to be the more accurate caresheet out there on the Chilean Rose!
     
  9. biollantefan54

    biollantefan54 Elite Member

    Well It is only working on Google Chrome and Mozilla Firefox is glitched and it won't load up so, :(

    And I am going to get one but I don't have one yet.
     
  10. biollantefan54

    biollantefan54 Elite Member

    Okay I think I got working again! :D
     

Share This Page